On 03/01/2014 01:15 AM, Will Deacon wrote:
On Fri, Feb 28, 2014 at 05:17:15AM +0000, AKASHI Takahiro wrote:
> This patch adds auditing functions on entry to or exit from
> every system call invocation.
>
> Acked-by: Richard Guy Briggs <rgb(a)redhat.com>
> Signed-off-by: AKASHI Takahiro <takahiro.akashi(a)linaro.org>
> ---
> arch/arm64/kernel/ptrace.c | 54 ++++++++++++++++++++++++++------------------
> 1 file changed, 32 insertions(+), 22 deletions(-)
I think you need to do something like I did for arch/arm/, where we have
separate trace functions for entry/exit to make sure that we invoke the
various helpers in the correct order (for example, you want to invoke all
the debug stuff *first* on entry, but *last* on exit).
Will
If you mean syscall_trace_enter()/exit(), I will follow your suggestion
for readability.
-Takahiro AKASHI