On Mon, Jan 6, 2020 at 3:23 PM Florian Westphal <fw(a)strlen.de> wrote:
Richard Guy Briggs <rgb(a)redhat.com> wrote:
> diff --git a/include/linux/audit.h b/include/linux/audit.h
> index 96cabb095eed..5eab4d898c26 100644
> --- a/include/linux/audit.h
> +++ b/include/linux/audit.h
> @@ -379,7 +379,7 @@ extern int __audit_log_bprm_fcaps(struct linux_binprm *bprm,
> extern void __audit_fanotify(unsigned int response);
> extern void __audit_tk_injoffset(struct timespec64 offset);
> extern void __audit_ntp_log(const struct audit_ntp_data *ad);
> -extern void __audit_nf_cfg(const char *name, u8 af, int nentries);
> +extern void __audit_nf_cfg(const char *name, u8 af, int nentries, int op);
Consider adding an enum instead of int op.
> if (audit_enabled)
> - audit_nf_cfg(repl->name, AF_BRIDGE, repl->nentries);
> + audit_nf_cfg(repl->name, AF_BRIDGE, repl->nentries, 1);
audit_nf_cfg(repl->name, AF_BRIDGE, repl->nentries, AUDIT_XT_OP_REPLACE);
... would be a bit more readable than '1'.
The name is just an example, you can pick something else.
I agree. Also, please just merge this into patch 4; I don't see a
solid reason why it shouldn't be there.
--
paul moore
www.paul-moore.com