On 2021-09-30 16:38, Paul Moore wrote:
> On Thu, Aug 5, 2021 at 6:01 PM Paul Moore <paul(a)paul-moore.com> wrote:
> > On Wed, May 19, 2021 at 4:01 PM Richard Guy Briggs <rgb(a)redhat.com>
wrote:
> > > Replace audit syscall class magic numbers with macros.
> > >
> > > This required putting the macros into new header file
> > > include/linux/auditsc_classmacros.h since the syscall macros were
> > > included for both 64 bit and 32 bit in any compat code, causing
> > > redefinition warnings.
> > >
> > > Signed-off-by: Richard Guy Briggs <rgb(a)redhat.com>
> > > Link:
https://lore.kernel.org/r/2300b1083a32aade7ae7efb95826e8f3f260b1df.162136...
> > > ---
> > > MAINTAINERS | 1 +
> > > arch/alpha/kernel/audit.c | 8 ++++----
> > > arch/ia64/kernel/audit.c | 8 ++++----
> > > arch/parisc/kernel/audit.c | 8 ++++----
> > > arch/parisc/kernel/compat_audit.c | 9 +++++----
> > > arch/powerpc/kernel/audit.c | 10 +++++-----
> > > arch/powerpc/kernel/compat_audit.c | 11 ++++++-----
> > > arch/s390/kernel/audit.c | 10 +++++-----
> > > arch/s390/kernel/compat_audit.c | 11 ++++++-----
> > > arch/sparc/kernel/audit.c | 10 +++++-----
> > > arch/sparc/kernel/compat_audit.c | 11 ++++++-----
> > > arch/x86/ia32/audit.c | 11 ++++++-----
> > > arch/x86/kernel/audit_64.c | 8 ++++----
> > > include/linux/audit.h | 1 +
> > > include/linux/auditsc_classmacros.h | 23 +++++++++++++++++++++++
> > > kernel/auditsc.c | 12 ++++++------
> > > lib/audit.c | 10 +++++-----
> > > lib/compat_audit.c | 11 ++++++-----
> > > 18 files changed, 102 insertions(+), 71 deletions(-)
> > > create mode 100644 include/linux/auditsc_classmacros.h
> >
> > ...
> >
> > > diff --git a/include/linux/auditsc_classmacros.h
b/include/linux/auditsc_classmacros.h
> > > new file mode 100644
> > > index 000000000000..18757d270961
> > > --- /dev/null
> > > +++ b/include/linux/auditsc_classmacros.h
> > > @@ -0,0 +1,23 @@
> > > +/* SPDX-License-Identifier: GPL-2.0-or-later */
> > > +/* auditsc_classmacros.h -- Auditing support syscall macros
> > > + *
> > > + * Copyright 2021 Red Hat Inc., Durham, North Carolina.
> > > + * All Rights Reserved.
> > > + *
> > > + * Author: Richard Guy Briggs <rgb(a)redhat.com>
> > > + */
> > > +#ifndef _LINUX_AUDITSCM_H_
> > > +#define _LINUX_AUDITSCM_H_
> > > +
> > > +enum auditsc_class_t {
> > > + AUDITSC_NATIVE = 0,
> > > + AUDITSC_COMPAT,
> > > + AUDITSC_OPEN,
> > > + AUDITSC_OPENAT,
> > > + AUDITSC_SOCKETCALL,
> > > + AUDITSC_EXECVE,
> > > +
> > > + AUDITSC_NVALS /* count */
> > > +};
> > > +
> > > +#endif
> >
> > My apologies Richard, for some reason I had it in my mind that this
> > series was waiting on you to answer a question and/or respin; however,
> > now that I'm clearing my patch queues looking for any stragglers I see
> > that isn't the case. Looking over the patchset I think it looks okay
> > to me, my only concern is that "auditsc_classmacros.h" is an awfully
> > specific header file name and could prove to be annoying if we want to
> > add to it in the future. What do you think about something like
> > "audit_arch.h" instead?
> >
> > If that change is okay with you I can go ahead and do the rename while
> > I'm merging the patches, I'll consider it penance for letting this
> > patchset sit for so long :/
>
> [NOTE: trimmed the To/CC line as it is excessive for a ping like this]
>
> Going through the patch queue and I see this never got a response, or
> rather none that hit my inbox. Richard?
Hmmm, sorry about that, delay my fault this time. I don't have a strong
opinion about it, but prefer the original, or auditsc_arch.h at least.
Okay, so long as you are okay with the header rename I'll go ahead and
take care of that, although probably not today as merging
cross-subsystem changes late on a Friday seems like a problem waiting
to happen.
I'll send another note when it is in audit/next.
--
paul moore